Upload failing and blinks not turning on after upload

So I just got my developer kit and was trying to upload a game onto one of the blinks. At first I was getting the message asking if I was sure if I was using the correct board under tools->board. I looked on the forum and saw other people had the same issue and they suggested downloading the file called Blinks-SDK-328. I did that and was able to get the new folder under tools->boards->move38. I chose the blink 328 option and started the upload with the publish tool. Halfway through the blink shut off and then got the error:
Sketch uses 5562 bytes (94%) of program storage space. Maximum is 5888 bytes.
Global variables use 776 bytes (75%) of dynamic memory, leaving 248 bytes for local variables. Maximum is 1024 bytes.
Low memory available, stability problems may occur.
avrdude: verification error, first mismatch at byte 0x3900
0x00 != 0x16
avrdude: verification error; content mismatch
avrdude: verification error; content mismatch

The blink no longer will turn on even with the battery connected (Yes I’m aware I can get a replacement by contacting support). I was reading another forum and it said to duplicate the Blinks-168pb.hex file and rename is BlinksBIOS.hex under the bootloaders folder. I did that and tried another blink and the same problem happened and now I have two blinks that are not functional. How can I successfully upload a game onto one of the blink? The game I’m trying to upload is shadowball which I got the code from github. I was able to successfully upload the game onto the developer blink but now I cant figure out how to save it onto one of my blank blinks. Any help is greatly appreciated.

I’m not an expert, but when they don’t turn on at all anymore, it sounds like you might have short circuited them. I heard it can happen, when the needles of the programmer tough any of the metal that is usually connected to the battery. To avoid that there is the tip to cover this contacts with the sticker, that usually covers the contacts for the programmer.

I was having the same problem, but I did not need to duplicate that file. You can see the thread here: Uploads keep failing

What worked for me was making sure that I…

  1. Double-check that my board selected is Board328
  2. Check that your Programmer is Blinks USBtinyISP
  3. Try pushing the game again even if the blink is off.

I had to restart my computer, use a different USB port for the cable and restart Arduino to make sure I wasn’t missing anything else. Being new to Arduino in general I forgot to double-check all of those settings when I loaded the example.

I was able to fix everything by going on github and clicking on “Raw” and copying and pasting onto a new file on arduino. Before i was just clicking the “copy” icon on github and pasting it onto arduino. For some reason going on file->new fixed it :woman_shrugging:. Support met with me on google meet and walked me through it. To fix the ones that wouldnt turn on I search on github “blanks” and did the same as state above and tried uploading again and they turned on.