Arduino not locating Blink Tile Board


#1

Hey people,

Excited to get my Blinks up and working, but having no tech experience seems to have backed me into a bit of a corner. I downloaded Arduino and the Blinks Library, which I unzipped and put in the hardware folder I made - all instructions from the quickstart guide - but now I’m stuck.

When I go to Tools>Board as instructed, the Move38: Blinks Tile option doesn’t appear. [image attached]

This probably won’t be the last thing I need help with (because SOMEHOW I made it past this on my laptop, but encountered other issues), but in the meantime… can anyone help with this? :slight_smile:

  • Josh, Brooklyn Game Lab


#2

Hi Josh!

Welcome to the community! Can you take a screenshot of the filepath of the Blinks libary?

C:\Users\<yourname>\Documents\Arduino\hardware\Move38-Blinks-Library\avr\

Due to the way the Arduino IDE reads new hardware types, the folder for the library that you download needs to be renamed avr and then the folder enclosing it can be named anything you feel appropriate, so I use Move38-Blinks-Library

Let me know if that fixes it for you. In this instance, you’ll need to restart Arduino to see the changes occur.

best,
jb


#3

Here is inside my Move38-Blinks-Library folder. Which folder do I need to rename as avr? The libraries folder?


#4

BlinksLib_Windows_Path


Not seeing library on Mac or PC
#5

Great. I made and avr folder and sent all that stuff to it.

But now that I’ve selected the correct board, programmer, and Example B-ButtonPress…

Arduino: 1.8.5 (Windows 10), Board: "Blinks Tile"

Sketch uses 3048 bytes (19%) of program storage space. Maximum is 15872 bytes.
Global variables use 171 bytes (16%) of dynamic memory, leaving 853 bytes for local variables. Maximum is 1024 bytes.
avrdude: initialization failed, rc=-1
** Double check connections and try again, or use -F to override**
** this check.**

An error occurred while uploading the sketch

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


#6

It turns out when I press on the prongs it can make the connection. Hmm.

Would adding felt to the top of the prongs (where I press) hinder the thing in any way? Trying to make it more comfortable.


#7

I apply a bit of pressure down on the connector which translates to the pogo pins. A sad truth is that the pogopins are ever so slightly too strong to make the connection without a little bit of pressure from above. Hopefully the magnets should get everything lined up and in place and then a little pressure from above should make the contact secure.


#8

My experience has been the same as Jonathan’s. Of course, this also assumes the battery is fine…