Blink became non-programmable

I have a Blinks that has worked fine for programming but is now producing an error when trying to write it. The jig works with other Blinks but not this one. I’ve tried restarting the Arduino IDE but am getting same behavior. Have you run into this behavior before? Since jig working on other Blinks I’m not suspecting the jig or cable? Anything else to check?? Thank you, Ken.

Most common reasons that the initialization fails.

  1. Programmer pins are not all making contact (apply a little pressure to the top of the programmer jig)
  2. The battery is not in contact (check to see if the screw is a bit loose… sometimes the pressure of the jig separates the contact)
  3. The battery is low/dead*

*It should take a while for you to see this issue… 50+ hours of active lights on time is our current measurement.

It is safe to reprogram the Blink with the programmer set to “power target” if the battery is not in the Blink (not the kindest thing to do with the Battery in the Blink). Sometimes this is all the Blink needs to be rewritten.

Let us know what works.

I made sure there was contact between jig and Blink so I don’t believe it was connectivity. I removed and reinserted the screw and it’s working again (no other changes). Looks like reason #2.