Dev kit fails to light up or teach

I just got my dev kit today. When I first attached it, it lit up, but it went dark in the time I took to look up and upload the colorwheel example. Arduino says the tutorial uploaded, but my dev blink did not light up even when I pressed the button and none of the blinks I linked to it appeared to learn anything. I also tried the buttonpress example with the same non-result.

Am I doing something wrong or is my dev kit broken?

Hi @Anaya,

Welcome and thanks for sharing! Can you take a quick photo of the setup so we can make sure your Dev Blink is hooked up correctly? I have a couple of guesses, but it is first helpful to see the Blink hooked up via USB and then secondly, helpful to see a screenshot of the completed upload from Arduino. It will say “Done uploading”

Can’t wait to get you up and running!

all my best,
Jonathan

Here are my setup and a screenshot of my upload.

:thinking: honestly a little surprised, always exciting to see something for the first time, and this is a first. Good thing is, we don’t stop til we get it workin’ for ya :slight_smile:

Hmmm, it is definitely uploading to the dev blinks so all your connections are good. Looks like you are doing everything right.

So maybe could be either a bad button or bad LEDs? Can you try uploading a very simple sketch like…

void setup() {
}
void loop() {
    setColor( WHITE );
}

…and see if you see any LEDs light up after it finishes the upload and verify cycle? By the time you see the “avrdude done.” message in the IDE, the code should be running on the blink.

Also maybe try unplugging the cable connected to the dev blink for maybe 10 seconds and then plug it back in again. The blink automatically gets a reset at the end of the upload, but maybe the chip is somehow in a very weird state?

Thanks!

Bigjosh, I tried running your program. I got the “avrdude done” message, but the blink’s lights did not turn on. At this point I have unplugged and reattached everything at least three times.

Let me know if you want to do some troubleshooting in the discord

1 Like

We think the issue was that I had installed the development build of Arduino rather than the stable build. For some reason, the development build was not reading the Blinks library (we still don’t know why), but installing the stable build (1.8.13 as of today) fixed the issue.

Thank you all!

I tried joining the discord, but don’t have permission to post anywhere and could not access the channels listed in the system map. I’ve never used discord before.

1 Like