Dev Kit Issues (teaching + serial)

Hey there. Just wanted to see if I could get some help on a few issues.

Firstly, after uploading, is it supposed to automatically teach connected blinks? Because it doesn’t seem to do so for me. After uploading, I need to disconnect it from other blinks, hold the button, then connect it.

Secondly, I can’t seem to get the serial output working. I open the serial monitor (set to 1M baud), upload, and no output when running the serial number printer example.

FYI, I installed via downloading this release:


via the How To Install instructions here:

The board manager json method would not work for me, as it would result in an error when opening the board manager.

It is, the reason it is not working is that you are using an older version of the SDK.

I actually had a similar issue and contacted support about it as, in my case, I am pretty sure the serial port in the dev Blink is busted. But you better try with the most recent SDK before assuming the problem is a hardware one, just in case.

This is the wrong one (note it is from 2019). You need to follow the instructions here:

What exactly issue did you have?

1 Like

I followed them initially but could not continue due to the error below.

When I open Boards Manager it says:
Error downloading https://boardsmanager.com/package_move38.com-blinks_index.json
When I go to that URL in my browser, it loads fine. I’m using Arduino 1.8.13, already tried disabling proxy settings.

EDIT:
I was just able to fix it, actually, by making it http instead of https. I figure that since Arduino is made in Java, it was probably something silly like that :joy:

Unfortunately it would appear my serial port is busted as well, as while the learning is now working, the serial output is not.

My serial issue was solved with this: