One blank not working with publish tool

I have a blink that won’t accept uploads via the publish tool. I get the following error message:

avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

Error during Upload: programming error: uploading error: exit status 1

The same code and command uploads error free to five other blanks I’ve tested. This blink will, however, learn from others via IR (most of the time - I’ve had it error into a red flashing state a few times)

Is this a faulty blank?

I’m getting the same error message. Although it’s on my Developer Blink that I just got in the mail 2 hours ago.
I don’t have any others to test with… well I guess I could attempt to overwrite one of my existing blinks, but I’m a bit worried.
I’m on windows 10, followed all the steps, installed the extra driver mentioned in the steps for windows machines.
I do see that my ports option under Tools is greyed out.
I found another article on this form that said to set the Serial.port to COM1. there wasn’t a serial.port listed in the preferences list… so I just created one and set it to com1. didn’t help.
My developer blink is lighting up.

Found it in another post. On the red board there’s a small switch. It was in the middle. make sure it’s set to “power target”

1 Like

How many red flashes? You can tell which error it is by the flash count, which might give more info on what is going on.

I’ve done some more testing, and it seems IR is broken on the ‘3’ face (0 indexed). When I try to teach another game via IR on that face, it flashes red three times. When I am able to successfully teach a game using one of the other faces, it is not sending or receiving signals on that face during gameplay, either.

I still cannot upload anything via the publish tool.

I now have a blank that was working fine but now can not accept uploads via the publishing tool anymore. Same generic error. It does light up when the publishing tool is connected.

bump… I cannot use this blink for development and don’t have any suggestions for a fix. Can I get a replacement? It has never worked, out of the box

Your best bet is contacting


We’ll take care of you :slight_smile: so we can track it with a ticket :raised_hands:

1 Like