Upload fails with "programmer operation not supported"

Hi, I just got my devkit and walked through the quick start guide. Unfortunately, I’m getting the error below whenever I try to upload to the blank. I can confirm that the blank is able to power on with the programmer attached and I’ve tried this on both my PC and my macbook with the same results.

avrdude: programmer operation not supported

avrdude: Setting SCK period to 5 usec
avrdude: initialization failed, rc=-1
        Double check connections and try again, or use -F to override
        this check.

full log

Hey gapMindful,

Glad you’ve got your kit in hand, but sorry about this speedbump.

I’m going to have to look more into that error code for now, but there are a few little troubleshooting tips I might suggest first:

  1. Try connecting the programmer pins in both orientations.
  2. In Arduino, open the “Tools” menu, then navigate down to Board. Make sure you have the Blinks board selected.
  3. In that same “Tools” menu, navigate down to Programmer and make sure that “Blinks USBtinyISP” is selected.
  4. If your dev kit has an accessible board (ie no 3D-printed encasement), check that the little switch is set to “Power Target.”

I will look into that message in the meantime, but hopefully one of those tips works for you.


thanks for the quick response. Tried both orientations and I get the same error. I can also confirm the programmer and blinks board selection. I actually removed the programmer from the enclosure to check if anything was disconnected, everything is looking good and its set to power target

Hmmm, can you include a screenshot and a photo of the setup? Feels like we should be able to get you up and running pretty quickly.

Here’s a picture of the Arduino IDE with the error and selected settings. Also a picture of how I’m actually connecting up the dev kit (Mac book air example, getting same error as the PC logs I uploaded from my desktop last night). Let me know if I can get you any other info and thanks again for the help.

This all looks correct. I’ll get a replacement Blank in the mail today. In the mean time, you can use the spudger to remove the sticker on another Blink and try to program one from your Core Set. This would also let us know that you did in fact receive a bad Blank. If it fails to program another Blink, then this suggests that the problem is somewhere else in the process.

looks like it was the blank. Just programmed one of the original six and it worked! I’ll DM you about getting the replacement. Looks like the “operation not supported” message was a false positive, still seeing that in the console out even though everything is working just fine.