USB port not recognized


I am putting together my Blinks Dev kit with my daughter (11) and we are running into some USB issues. I am getting the following error when I plug in the programming board to my machine:

Device Manager - Unknown USB Device (Device Descriptor Request Failed)

Searching through the support it looks like this has happened to people before, but none of the fixes have worked for us. I have tested this on my Desktop and Laptop both running Windows 10. Both machines were originally Windows 7 and have been upgraded. I installed the adafruit driver referenced here:

Even after a restart and trying alternate cables and alternate (non-USB-3) ports, I still get the same error. The only thing that seems to work is the USB power, as the programmer board and the dev blinks both light up.

We’re kind of stuck right now. I’m hoping the answer isn’t "You need a new computer with a different USB chipset, " but this is the only thing that I have been able to glean from the adafruit support pages. It may be that I am just not skilled enough in forcing Win 10 to pick the right driver.

Anyway, here is a screenshot in case it helps: (apparently, I can only attach one)


A second screenshot showing the USB port is not recognized.

It does look like you did not download the correct driver. Can you provide a link? I THINK I used this one here:

That is where I got my driver. The big green button in the middle of the page leads to the github link that I referenced, which is the Adafruit drivers v It does seem that these drivers are for Win 7, 8 & XP, but the github page implies that they work on Win 10.

This is the direct link to the package:


Looking at your screenshot, the “Device Descriptor Request failed” error might indicate an actual issue with the programmer. I guess your best bet now is contacting directly and see if they can help troubleshooting or even sending you a new programmer if needed.