(vscode) trouble uploading [Cant Find Programmer]

I must be missing something… all im missing is the ability to upload.
i get: “Error during Upload: A programmer is required to upload”
ive tried everything within my knowledge and research.
i think everything is correct. LMK if you need me to supply .txt configs

Did you get it working with Arduino IDE. I suggest you do that first and only them try VSCode. Also, did you install the required drivers?

I’m very new to all this. Yes it works great on Arduino. What drivers are you referring to? Also i posted this out of frustration so let me include another screenshot.

You could try enabling verbose output and see if anything pops out of that.

In your project’s .vscode directory, create settings.json and include the following:

“arduino.logLevel”: “verbose”

Also, my programmer looks slightly different, though I don’t know if that means anything.


I changed the programmer to “Blink USBtinyISP” via the programmer selector. Seems to be displaying the gcc compile commands now with the “arduino.logLevel”: “verbose” but its the same error.

SOLVED IT!! had to re edit my c_cpp_properties.json again. Getting out of Arduino - #11 by finiteattractor

1 Like