Can't upload - port does not exist

Hi all, I just got my Blinks from the Kickstarter a couple of days ago and I’m having a lot of fun with them. I wanna try programming with them, but I’m having trouble getting started. I have Arduino and the SDK all set up. The board is set to Blink and the programmer is set to USBtinyISP. I’ve installed the Windows driver for USBtiny. However, I can’t upload the example programs, I get an error that the serial port doesn’t exist/the board is not connected, like this:

avrdude: Version 6.3-20190619
    Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
    Copyright (c) 2007-2014 Joerg Wunsch
    System wide configuration file is "C:\Users\charl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"
    Using Port                    : usb
    Using Programmer              : usbtiny
    Setting bit clk period        : 5.0
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)
avrdude done.  Thank you.
the selected serial port 
does not exist or your board is not connected

I’ve tried the advice in these threads to no avail:


Notably, the drivers don’t show up in my Device Manager (even with the option to show all checked). The developer Blink gets powered, everything lights up. I just can’t seem to upload to it. I’ve tried a few different USB connections, no dice. I’m using a Surface Laptop 3. I noticed one of those threads was also using a Surface device, so I wonder if there’s a correlation? Any tips would be appreciated, I’m dying to get to mess around with the devkit. Thanks!

Do you see USBTiny listed in device manager when you connect the Dev Blink? Do you get any notification from Windows when it is connected?

Based on your description it might either be a driver or hardware issue.

Nope, it’s not listed and there’s no connection notification or anything else of the sort. Maybe I’ll try a different machine later.

Let me know if you want to join the discord and you can share your screen. I just did it so think we could get it working quickly.

Hi @minimus,

This looks like a driver issue from first glance, looks like the community is helping out, but wanted to lend a hand and make sure we get you up and running with your developer kit. Let me know if you are still having no luck with the computer recognizing the USBtiny programmer after installing the driver from Adafruit and restarting your machine.

all my best,
Jonathan

In case you haven’t solved this yet, I had a similar issue just now and went to adafruit’s forums and installed the drivers here:

Now it registers as libusb-win32 devices > USBtiny

Hope this helps!

I hate to admit this, but I tried to program the blinks without removing the clear protective sticker over the ports. I received the same message. My son laughed at me. After removing the sticker all is well!

1 Like

Thanks for the replies, everyone. I was able to get the drivers to show up in my device manager but it didn’t solve the issue. I talked with some folks on the Discord and they think my programmer (the AVR pocket programmer) is busted and I’m inclined to agree. When they plug in their programmers, 3 lights light up on the board. For me, only the power light lights up when plugged in. We even tested using Raspberry Pis with nothing else installed, mine didn’t light up properly while theirs did. I’ve gotten in touch with support.