Port on Windows


I have followed the Quickstart guide and can compile examples. What doesn’t work is the transfer, Arduino tells me to select a port. I can’t select a port, the entry “port” in the Tool-menu is grayed out.

Please advise, it’s probably a small thing.


Hi there,

If your machine does not actually have any COM ports, which I suspect is the case, there is a solution posted below that will help you out.



1 Like

Hi!, thanks, yes, my machine does not have actual COM ports, just USB, exactly.

I can’t find a upload.verify setting in Preferences (screen shot below), I can’t find a settings menu and there doesn’t seem to be a configuration part in the “game” either (currently looking at A-MortalsGame). I can’t find a serial.port setting either and can’t select the port in ports.

Am I looking in the right app? The title bar says “A-MortalsGame | Arduino 1.8.7”, I can see a cyan colored logo with a minus and a plus symbol, each in its circle.


Update… Thanks, MikeSynnott, for your research – I’m one step further now, I have changed the preferences.txt manually and set the port to COM1, that particular error message is gone now.

New message:
"avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

The USB cable is connected, the small board lights up blue and red, the orange adapter is connected to a blink, the blink pulses red.

1 Like

Update 2… I give up, after spending a lot of hours getting it to work.

I have googled for the error message, it pointed me to a hint about USB 3 being unsupported. So I tried a “cheap USB hub”, as advised – no change.

So I googled some more… And downloaded the “Pocket AVR Programmer” tool, and set the “Unknown Device #1” to “libusb-win32” and tried my luck again. - https://learn.sparkfun.com/tutorials/pocket-avr-programmer-hookup-guide

Result: One blink doesn’t even run the demo app any longer, it’s just dead. I cannot “start” it with a fork either, it does not light up any more. Also, after a “promising” start, at least something changed, now all I get:

“avrdude: Yikes! Invalid device signature. Double check connections and try again”.

This now happens for every blink I tried and I’m afraid of breaking some more. So instead of being able to access more games than with the “regular” blinks, I now spend a lot of time fixing the “button” and trying to program that thing to get at least one working game – no chance.

I give up. This sucks.

Hi Rene,

You sound so close to the finish line, and as an early adopter, not dev, I am more than impressed by your technical chops. Check your direct messages, we’ll see what we can do to get your Blinks up and running. I have a feeling there are a couple of tips and tricks that might do it and if so, we can make sure they are well documented for the next person.

all my best,

1 Like

Ok, thank you. Let’s try.

1 Like

“avrdude: Yikes! Invalid device signature. Double check connections and try again”.

When I get this error, it’s because there is not a solid connection between the Blink and the programming rig.

The trick is to pinch the rig and the Blink together, as shown in the attached photo, to create a solid connection between the two. I do this every time I’m programming a Blink now, out of habit, and I never have a problem.


Unbelievable – it worked!! :slight_smile:

I could even revieve the “broken” blinks with that.

On the programmer, more lights light up and when they go out, the Arduino IDE says “Done uploading” – done.

Will now finally be able to try out the games. Thank you!

1 Like

Yeah, I found that analysing the problem and working it methodically was really worthwhile.