Not seeing library on Mac or PC

I have installed Arduino 1.8.6 (PC) and the latest on Mac. I have constructed the hardware folders and placed the blink libraries inside them, but when I run the Arduino it does not recognize the board connected to the USB

I have even tried to load the library file but it says } no vaold hardware definitions in folder variants.

This is the same on the Mac side and the PC side - same ignoring behavior on both.

What could cause this?

Hi @Ironclad!

The most common reason for this is folder structure, double check that it is like this

My other thought is that unlike with Arduino boards, the Blink won’t show up in the list of USB ports. This is because we are not programming over serial, we are using an ISP to flash the hardware. So no need to select port when uploading, just the correct programmer.

Let me know if that does it.


I have tried pressing harder with no luck - reinstalling drivers on the PC side and reconnecting the plugs in all boards. I took photos of what I have on the Mac and PC sides of my unit

What is the “correct” programmer too?

It isn’t working as shown - bottom line

Thanks for posting the images, it makes this very clear.

The issues is the folder structure. Look at the attached image that shows where your folder structure can be corrected. You will need to create a folder called “Move38-Blinks-Library” then inside of it, a folder called “avr.” This avr folder is where that entire Blinks Library lives. Once you have it in that place, quit Arduino and relaunch it. You should now see at the bottom of your Boards list the addition of 2 kinds of Blinks hardware, the “Blinks Tile” is the one you want.

Just in case, here is the folder structure in text form:

  • :file_folder:Documents
    • :file_folder:Arduino
      • :file_folder:hardware
        • :file_folder:Move38-Blinks-Library
          • :file_folder:avr
            • :file_folder:AS7
            • :file_folder:cores
            • :file_folder:docs
            • :file_folder:libraries
            • :file_folder:variants
            • :page_facing_up: boards.txt
            • :page_facing_up: keywords.txt
            • :page_facing_up: platform.txt
      • :file_folder:libraries
      • :file_folder:blinks games
        • :file_folder:game1
          • :page_facing_up: game1.ino
        • :file_folder:game2

That worked - thank you.
But that is no where near what the quickstart documentation page says to do - nor was it the way the zip file unpacked.

Thanks @Ironclad,
we are looking to improve every step of the way, if you can make any suggestions for the quickstart guide based on your experience, it can be updated to help others.
Also, if you can mark the response as solved with the reply that solved it, that would be awesome! :slight_smile:

@Ironclad, I just made an update here. It’s a little lengthier but I believe more accurate now. Let me know if that matches your process. Thanks for such helpful feedback.


Thank you - I hope the new explanation makes it easier for others.

The biggest problem that I am having now is not have a single place to find the basic commands and an explanation of how they are intended to work - the definitions are scattered all over the move38 and github sites AND you frequently discover that some older commands are not recommended to be used.

The other thing that is SORELY missing is code for different games or functions.

Let me cite a specific issue - in the old mortals code it said reset by pressing 3 times. Great - how fast? because 3 presses rarely seem to do anything That and even how to START the play isn’t clear.

A couple of useful links. These are great requests, keep 'em coming.

There’s a known problem that sometimes button presses are missed (depends on which Blink OS function you’re using to detect it). They are sync’ing up the code that is supposed to fix this issue. I’m looking forward to a future Blink OS update with that updated fix.